Cloud Communication Issue - Trimble Access

Incident Report for Intelek Technologies

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 08:35 CDT

Identified

We have identified an issue affecting communications to on files awaiting pickup by Trimble Access customer base. This issue only effects Trimble Access customers and Trimble has confirmed knowledge of the issue. It is recommended that customers reach out to your shipping partners to ensure no loads are lost and to contact Trimble for updates on a resolution to the issue. Intelek will continue to hold files and monitor recovery once the issues are resolved.
Posted Jun 05, 2025 - 08:35 CDT
This incident affected: Cloud Communication.